Member: Jetfire1












Member: 62oldsf85












Member: JetfireGuy











XTR Prototype
(courtesy of General Motors)












Member: JimNoel











Member: JimNoel
Custom 1962 Jetfire Wagon

Home Blog Blog 1963 Olds Jetfire Re-restoration

1963 Olds Jetfire Re-restoration

Home Page Forums Discussion Topics – Ask the Experts 1963 Olds Jetfire Re-restoration

This topic contains 51 replies, has 8 voices, and was last updated by  captiannapalm 3 weeks, 3 days ago.

Viewing 10 posts - 41 through 50 (of 52 total)
  • Author
    Posts
  • #12487

    kid442
    Participant

    Just installed all the exterior trim. Next weather strips and gaskets. Took it out for a couple mile drive. Checked out OK. Getting closer.

    Attachments:
    #12490

    kid442
    Participant

    Quick video of the first test drive.
    https://youtu.be/aoiH2nsW_W4

    #12688

    kid442
    Participant

    Just put 110 miles on the car in the last week. Runs great. Had the muffler shop install a Waldron’s exhaust system I purchased. Four hours later and a bunch of $$$ but came out great. Still have a few gaskets more and a bunch of other items but the list is getting shorter.

    Attachments:
    #12691

    macf85
    Participant

    Lookin’ good Ken!

    #12692

    kid442
    Participant

    Mac
    Thanks!
    Ken

    #12704

    kid442
    Participant

    Quick update. Painted the wheels white. I think it’s a big improvement! New wheels and tires are for this winter. Not sure what we may do. Change to 5 lug or order custom wheels. For now drive the wheels off of it.

    [blockquote]BBCode you used is not allowed.[/blockquote]

    Attachments:
    #12995

    kid442
    Participant

    OK here is the latest update. Just installed a posi rear new shocks and 1/2″ lowering springs. The rear is from a 1961 Buick Special and there were a bunch of changes made the Job much harder than needed. A little farmer engineering and its in. Going to get the car to the Hershey AACA car show this Oct.

    Attachments:
    #13007

    wag-on
    Participant

    Nice progress. Keep up the great work

    #13008

    kid442
    Participant

    Thanks for the reply. I will attach a few photos

    [blockquote]BBCode you used is not allowed.[/blockquote]

    [blockquote]BBCode you used is not allowed.[/blockquote]

    [blockquote]BBCode you used is not allowed.[/blockquote]

    Attachments:
    #13011

    JimNoel
    Participant

    Hi Ken,
    I assume that you are posting pics with your recent posts. They only show as [blockquote]BBCode you used is not allowed.[/blockquote] for me? Can you post in some other way? I would like to see them.

Viewing 10 posts - 41 through 50 (of 52 total)

You must be logged in to reply to this topic.

New Posts in the Forum

No topics found

Recently Active

Profile picture of jensenracing77
Profile picture of Greg Oakley
Profile picture of john-sage
Profile picture of perkinsrk1963
Profile picture of kyle otte
Profile picture of Ken Dennison
Profile picture of testguy
Profile picture of Felix j garcia
Profile picture of 62 Cutlass Convert
Profile picture of Jim Noel
Profile picture of TheOtherDave
Profile picture of scott
Profile picture of joe_padavano
Profile picture of matt zischkau
Profile picture of ray arnold

Who’s Online

Profile picture of jensenracing77