Member: Jetfire1












Member: 62oldsf85












Member: JetfireGuy











XTR Prototype
(courtesy of General Motors)












Member: JimNoel











Member: JimNoel
Custom 1962 Jetfire Wagon

Home Blog Blog ERROR 404

ERROR 404

This topic contains 8 replies, has 6 voices, and was last updated by  mackemp 2 weeks, 5 days ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #13734

    johnsage
    Participant

    Anybody else getting ERROR 404 when trying to get to most areas on this site?

    #13735

    jensenracing77
    Participant

    Yes, I am getting it also.

    #13736

    mackemp
    Participant

    Have been getting this Error 404 for the last 2 days. How do we get it fixed?

    #13738

    perkinsrk1963
    Keymaster

    Guys,
    This is Rick Perkins. My father is Jim Perkins (jetfireguy). He started this website and I’ve been taking care of it for him for several years now. I’m sad to tell you that he passed away suddenly in January with complications related to his Parkinson’s disease. I found recently that his credit card was used to pay for the site. Since he passed away, his card was cancelled. I believe that is why you were receiving the 404 errors. I’ve updated the site to use my credit card now. Please let me know if you have any more issues.
    Thanks,
    Rick

    #13739

    johnsage
    Participant

    Sorry to hear about your father Rick. This is a great website that he started, enjoyed by many. Probably most of us didn’t realize, or never thought about it, that there are expenses involved with maintaining such a website. If you don’t mind, please PM me concerning those expenses.

    #13740

    macf85
    Participant

    Rick,

    Thanks for all you and your dad Jim did to create and maintain this website. The only one of its kind. My condolences to you and your family. Count me in too.

    #13741

    captiannapalm
    Participant

    So sorry for your loss.

    #13749

    johnsage
    Participant

    Still having issues with ERROR404 !

    #13750

    mackemp
    Participant

    Still can’t get on most areas of our site. Error 404 is still there.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

New Posts in the Forum

No topics found

Recently Active

Profile picture of 62cutlassconvert
Profile picture of kid442
Profile picture of crj315
Profile picture of felixjgarcia
Profile picture of clintbowers
Profile picture of twobolts
Profile picture of jensenracing77
Profile picture of bstang
Profile picture of joe_padavano
Profile picture of mikeb
Profile picture of jcassel250
Profile picture of tbirdz12
Profile picture of johnsage
Profile picture of captiannapalm
Profile picture of arthurjones

Who’s Online

There are no users currently online