Help! Is this a casting flaw?

Home Page Forums Discussion Topics – Ask the Experts Help! Is this a casting flaw?

Viewing 10 posts - 1 through 10 (of 11 total)
  • Author
    Posts
  • #12319
    rosecityOlds
    Participant

    Took my water pump off my spare motor and saw hole and craters in the casting. Was this from faulty production? Has any one else seen this? Did something else go wrong to cause this?

    Attachments:
    #12321
    62cutlassconvert
    Participant

    Welcome to electrolysis. Pretty common in these engines. Make sure your antifreeze is current. Might want to change it if its 2+ years, Is there no impeller left at all!!? Having an overheating problem?

    #12322
    rosecityOlds
    Participant

    It was a motor that sat for ten years, but is supposed to have 30k on the rebuild.. Do you think the whole motor is eaten alive on the inside? Should I not assume it’s OK to run? I’m feeling a little nervous..

    #12323
    jensenracing77
    Participant

    No way to know for sure but it is likely ok. My 4 speed Jetfire was not ran since 1974 and it eat alot of stuff up but everything will be ok other than the intake manifold. It eat all the way through from the water port to an intake port.

    #12324
    jensenracing77
    Participant

    Did you clean it or is this picture as you found it? If it is as you found it I would say this was done before the rebuild. As clean as it looks I don’t think it is from sitting the past 10 years. Were the water passages empty while it sit the past 10 years? I would bet you are ok and this is from long ago.

    #12325
    rosecityOlds
    Participant

    There was coolant that came out of it when I tool the water pump off, and I took this picture shortly after doing so. It sounds like it would of needed more time than that to of eroded that much? I will look at my intake to see how that’s doin. Worst case scenario, I have to swap that too.

    #12326
    62cutlassconvert
    Participant

    I agree, that picture looks so clean, the active electrolysis doesn’t look that bad, and the impeller vanes are gone. Stupid question- Is it somehow backwards? How do the front cover inlets that mate up with the waterpump look? Those areas on the pump look good.

    #12330
    rosecityOlds
    Participant

    The areas are good. If I can’t easily get timing cover set, I am going to let it be.

    #12334
    62cutlassconvert
    Participant

    So what’s the deal on the impeller?

    Does the timing cover interface on the block look good too? Had to weld mine.

    #12335
    rosecityOlds
    Participant

    The picture is of the timing cover. The impeller on the water pump looked ok. I’ll take another look at it t’night after work.

Viewing 10 posts - 1 through 10 (of 11 total)
  • You must be logged in to reply to this topic.

Recent Articles

Turbo System Safety Checks

Turbo System Safety Checks

The safety components of the factory designed turbo system have some interactive groups of safety "c...(read article)

Engine Front Drive Pulleys

Engine Front Drive Pulleys

The standard drive pulley has one groove. It drives the water pump/fan and alternator or generator. ...(read article)

1961-1963 F85 Car and Option Prices

1961-1963 F85 Car and Option Prices

Attached to this article is PDF file containing an extensive list of car and option pricing for 1961...(read article)

Recently Active Members

Profile picture of jensenracing77
Profile picture of 62cutlassconvert
Profile picture of joe_padavano
Profile picture of jvficek
Profile picture of graytoad

OldsJetfire Forum