Hydra-Matic issues

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #10686
    jensenracing77
    Participant

    Last October when I was in Minnesota my wife was driving the Jetfire. She called me and said she was having transmission troubles. I got home and sure enough the transmission was bad. I knew I had problems with it earlier in the year because the fluid burned up and turned dark. I pulled it out this past spring and got it back to the transmission guy. He found that in fact the TV rod had been adjusted correct so I felt good that I at least didn’t cause the problem. He found that the rings were made of a different material from what was used back in the day and wore out the ring grooves in the governor. He talked to some of his sources and discovered that back in the day Olds had a service replacement governor that was made of cast iron. He somehow located an NOS one and installed it. He is telling me that I will NEVER have that problem again with the updated part. We are planing a trip to Indy on labor day weekend so i have got to get it back together and test it a couple days. Maybe by the end of the day Saturday I can drive it again.

    Attachments:
    #10688
    jensenracing77
    Participant

    Tonight went much better than expected. I have it bolted in and everything hooked up. I have to get transmission fluid in the morning and install the driveshaft. I plan to install my new radiator hoses also. I wanted to do them last year but never got around to it.

    Next project will be the rear end and brakes. I have got to find a center section for it. My spider gears have worn into the housing and I fear that it will brake if i use it to hard. Also plan to update the brakes to a self adjusting setup.

    #10689
    jensenracing77
    Participant

    Works great! Took it for two drives today and everything went great. Only issue I have is that i think the NOS decompression valve went bad. I have the rebuilt one from Jim I will install and should be good again.

    #10690
    jensenracing77
    Participant

    Don’t know how to edit a post here. last post should say depressurization valve, not decompression valve.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Recent Articles

Turbo System Safety Checks

Turbo System Safety Checks

The safety components of the factory designed turbo system have some interactive groups of safety "c...(read article)

Engine Front Drive Pulleys

Engine Front Drive Pulleys

The standard drive pulley has one groove. It drives the water pump/fan and alternator or generator. ...(read article)

1961-1963 F85 Car and Option Prices

1961-1963 F85 Car and Option Prices

Attached to this article is PDF file containing an extensive list of car and option pricing for 1961...(read article)

Recently Active Members

Profile picture of rusty63
Profile picture of 62cutlassconvert
Profile picture of joe_padavano
Profile picture of JimNoel
Profile picture of steveharclerode

OldsJetfire Forum